Loot card says already redeemed

View previous topic View next topic Go down

Loot card says already redeemed

Post  shouraku on Fri Jun 11, 2010 10:35 am

Good day everyone Smile

I have a loot card issue. I was told by Upperdeck to call Blizzard Billing and Blizzard Billing told me to contact you (being bounced all over!).

I recently purchased a booster pack that contained the loot card for "Tuskarr Kite" on 06/07/2010. I purchased the pack, opened it, scratched the card, and entered the code at:

http://www.worldofwarcraft.com/misc/promotion.html

With the correct realm and region (Uldum, US) .I received a message:

"Your promotion code has already been redeemed for a promotional item on the realm "Dath'Remar" (United States)."

I tried this multiple times to make sure that I had the code typed exactly as it showed on the card and am sure that I got all the necessary information correct. Each time I received the same response. I know that this card could have never been used before as I purchased,scratched, and entered the code myself. The pack was unopened and undamaged when I purchased it and since I live alone I am sure that no one has touched it but myself (quite perplexing).

Please advise me of what can be done to remedy this situation.

Have a good day,

Shouraku

shouraku

Posts : 5
Join date : 2010-06-11

Back to top Go down

Re: Loot card says already redeemed

Post  Damio on Fri Jun 11, 2010 10:48 am

shouraku wrote:Good day everyone Smile

I have a loot card issue. I was told by Upperdeck to call Blizzard Billing and Blizzard Billing told me to contact you (being bounced all over!).

I recently purchased a booster pack that contained the loot card for "Tuskarr Kite" on 06/07/2010. I purchased the pack, opened it, scratched the card, and entered the code at:

http://www.worldofwarcraft.com/misc/promotion.html

With the correct realm and region (Uldum, US) .I received a message:

"Your promotion code has already been redeemed for a promotional item on the realm "Dath'Remar" (United States)."

I tried this multiple times to make sure that I had the code typed exactly as it showed on the card and am sure that I got all the necessary information correct. Each time I received the same response. I know that this card could have never been used before as I purchased,scratched, and entered the code myself. The pack was unopened and undamaged when I purchased it and since I live alone I am sure that no one has touched it but myself (quite perplexing).

Please advise me of what can be done to remedy this situation.

Have a good day,

Shouraku

you certain you didn't accidentally redeem it on dath'ramar realm first then tried to re-do it on uldum?

Damio

Posts : 356
Join date : 2010-03-25
Location : somewhere in the UK if you know where, please tell me because i don't

Back to top Go down

Re: Loot card says already redeemed

Post  shouraku on Fri Jun 11, 2010 10:51 am

Yes of that I am sure. It says on the site that you have to be very careful of what region and realm that you enter. It also has a confirmation pop-up to show you what region and realm you have selected (yes to send in data / no to reenter type of pop up).

Thus I am sure that It was the correct realm and region.

Edit: After some research, it turns out that I am not the only person who has had this issue:

http://forums.worldofwarcraft.com/thread.html?topicId=22049839819&postId=227467641708&sid

shouraku

Posts : 5
Join date : 2010-06-11

Back to top Go down

Re: Loot card says already redeemed

Post  Damio on Fri Jun 11, 2010 11:19 am

shouraku wrote:Yes of that I am sure. It says on the site that you have to be very careful of what region and realm that you enter. It also has a confirmation pop-up to show you what region and realm you have selected (yes to send in data / no to reenter type of pop up).

Thus I am sure that It was the correct realm and region.

Edit: After some research, it turns out that I am not the only person who has had this issue:

http://forums.worldofwarcraft.com/thread.html?topicId=22049839819&postId=227467641708&sid

i know these seems dumb, but have you tried using the code it provided on your server im sure ive heard of one guy where it worked so he put it down to been a error on the redemption site, other than that it is beyond me

Damio

Posts : 356
Join date : 2010-03-25
Location : somewhere in the UK if you know where, please tell me because i don't

Back to top Go down

Re: Loot card says already redeemed

Post  shouraku on Fri Jun 11, 2010 11:34 am

I had not thought of that Damio. I just logged on and tried it to be sure. Disabled addons, deleted WTF folder, and copied the code from the Blizzard site to make sure there were no typographical errors. When that didn't work I tried typing the code in manually a few times, and it still did not work.

Just out of curiosity I made a character on Dath'Remar, went to Lando, and used the retrieval code that the Blizzard site gave. Apparently this code really has been redeemed at some point by someone as Lando shows that code still not being valid (could not validate). I really cant see how this could have happened, the card was inside of a foil wrapper that was contained inside of a box wrapped in plastic. You would have to be Houdini to get the card out and back in, and even then the layer of metal that you have to scratch off was perfectly intact until I personally scratched it off.

shouraku

Posts : 5
Join date : 2010-06-11

Back to top Go down

Re: Loot card says already redeemed

Post  Damio on Fri Jun 11, 2010 11:42 am

shouraku wrote:I had not thought of that Damio. I just logged on and tried it to be sure. Disabled addons, deleted WTF folder, and copied the code from the Blizzard site to make sure there were no typographical errors. When that didn't work I tried typing the code in manually a few times, and it still did not work.

Just out of curiosity I made a character on Dath'Remar, went to Lando, and used the retrieval code that the Blizzard site gave. Apparently this code really has been redeemed at some point by someone as Lando shows that code still not being valid (could not validate). I really cant see how this could have happened, the card was inside of a foil wrapper that was contained inside of a box wrapped in plastic. You would have to be Houdini to get the card out and back in, and even then the layer of metal that you have to scratch off was perfectly intact until I personally scratched it off.

was the plastic shrink wrap around the box the official Cryptozoic one? (it has there logo all over it) and i don't think it says couldn't validate code if its redeemed it should say code used, i cant suggest anything else, ur gonna have to wait for a Cryptozoic staff reply

Damio

Posts : 356
Join date : 2010-03-25
Location : somewhere in the UK if you know where, please tell me because i don't

Back to top Go down

Re: Loot card says already redeemed

Post  shouraku on Fri Jun 11, 2010 11:50 am

Yes it was official and showed no signs of having been unwrapped/re-wrapped (the box nor the foil) and there was no indication that that the metal coating over the code had ever been touched. I don't think that it could have been a forged box as I bought it from a reputable chain store. Besides it would have cost way more to produce a forgery this accurate then the actual cost of the original product.

I will wait for a staff post, but thank you again for trying Damio Very Happy

shouraku

Posts : 5
Join date : 2010-06-11

Back to top Go down

Re: Loot card says already redeemed

Post  DrWily on Fri Jun 11, 2010 1:58 pm

I've had this issue in the past and it is resolved by Blizzard support, not CZE or UDE.
They host the code generation site that redeems the code on the cards, and if there is an error you can provide picture proof to their support that you do indeed own the card.
There may be more info on the WoW forums or if you just email their support directly:
http://www.blizzard.com/support/webform.xml
Hope that helps!
-Lenny

DrWily

Posts : 75
Join date : 2010-03-24
Age : 36
Location : Raleigh, NC

Back to top Go down

Re: Loot card says already redeemed

Post  shouraku on Fri Jun 11, 2010 2:11 pm

Thank you Lenny for your response.

However, I have called multiple departments at Blizzard and have talked to Billing, Support, General, and even contacted an in game GM. I have spent close to four hours on the phone with their different departments trying to get this resolved. Have searched all over Blizzards and Upperdecks forums and called all the suggested numbers and emailed all of the suggested addresses provided there. I have offered to send them a scan of the card, to send them pictures of the packaging, whatever they want! Still, Blizzard keeps referring back here.

I realize that Blizzard hosts the code generation site that redeems the code, however, the fact that Blizzard representatives repeatedly told me to contact Cryptozoic makes me want to exhaust all my options here before I resume begging Blizzard for assistance.

shouraku

Posts : 5
Join date : 2010-06-11

Back to top Go down

Re: Loot card says already redeemed

Post  Roshen on Mon Jun 14, 2010 12:53 pm

Hello Shouraku,

You should have received a response to your email about this issue today.

In addition, I revised the Loot card FAQ found here: http://cryptozoic.finddiscussion.com/help-and-customer-service-f3/loot-card-faq-t1634.htm

_________________
Ry Schueller
Cryptozoic Entertainment


Roshen
CZE Employee

Posts : 180
Join date : 2010-03-31

Back to top Go down

Re: Loot card says already redeemed

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum